How to enable SEO in Joomla - Troubleshooting

Article Index
How to enable SEO in Joomla
Configuration and Rename of .htaccess
Joomla SEO Settings
Troubleshooting
All Pages

6. Troubleshooting

In case you get error messages from Apache, after you enable the SEO settings (like 404 file not found or 500 internal server error), then you have to:

  • Visit the website with Joomla's technical requirements to make sure that you meet at least the minimum of these.
  • Double-check that you renamed the file "htaccess.txt" to ".htaccess" and that you uploaded it to Joomla's root directory.
  • Ask your web hosting provider if he does have Apache's extension mod_rewrite installed on the server and ofcourse that they allow you to use .htaccess files.
  • Modify the .htaccess file, as I have indicated above, in case you have installed Joomla in a subfolder of your web-space, or if your web host told you to change something specific.

7. Last Resort

If none of the above help or the hosting provider doesn't allow the use of mod_rewrite in Apache, you can:

  • Enable only the first and the third SEO setting (Chapter 5). Click on "No" for the setting "Use Apache mod_rewrite" and on the upper right on "Apply". Then rename the ".htaccess" file back to "htaccess.txt", since you don't need it anymore. In this way you're going to have at least friendlier URLs than before.
  • Post your issue on the Joomla Forum with all details about the server environment on which Joomla is installed (PHP, MySQL and Apache versions etc.).


Comments  

 
#12 shiva 2012-04-08 14:12
Hello, I've enabled seo and submitted site map as well but still i'm not able to see the site in google. what could be the reason... please suggest me the settings and my site seo has done by godaddy.
 
 
#11 roland 2012-01-21 22:42
hallo zusammen,

weiss jemand, ob das problem virtuemart vs SEO in der Version 2.0.0 gelöst wurde? Ich möchte nämlich kein Geld für die yagendo lösung ausgeben müssen.
 
 
#10 miguel 2010-05-17 02:33
Quoting CosmicMatrox:
Quoting Benne:
Hallo zusammen,
also ich habe alles wie oben gemacht (benutze Joomla 1.5) außer das mit dem mod_rewrite. Jedoch verschwindet bei mir das komplette desing, wenn ich jetzt eine seite aufrufe. Woran kann das liegen ?


Ist bei mir das gleiche.
Jemand eine Idee ?


auch ich das gleich problem :-? , sobald Suchmaschinenfreundliche URLs auf ja steht funktioniert nur die "Startseite", Verlinkungen der Seite werden duchgewürfeld ohne Bilder und ohne Template angezeigt :cry: :cry:
 
 
#9 CosmicMatrox 2010-05-02 12:20
Quoting Benne:
Hallo zusammen,
also ich habe alles wie oben gemacht (benutze Joomla 1.5) außer das mit dem mod_rewrite. Jedoch verschwindet bei mir das komplette desing, wenn ich jetzt eine seite aufrufe. Woran kann das liegen ?


Ist bei mir das gleiche.
Jemand eine Idee ?
 
 
#8 Benne 2010-03-28 14:07
Hallo zusammen,
also ich habe alles wie oben gemacht (benutze Joomla 1.5) außer das mit dem mod_rewrite. Jedoch verschwindet bei mir das komplette desing, wenn ich jetzt eine seite aufrufe. Woran kann das liegen ?
 
 
#7 Yannick 2009-10-10 13:32
Mittlerweile gibt es aber eine gute Lösung für Virtuemart und SEO, dazu nutzt man das Core eigene SEF und eine extra Datei die man in den Virtuemart Ordner läd und schon hat man perfekte Virtuemart SEF Links ohne Komponenten wie sh404 und Artio welche die Probleme mit sich bringen. Hier findet man das Yagendoo (wir) Virtuemart SEO (yagendoo.com/.../...) hoffe das ganze wird nicht als Werbung sondern als hilfreicher Tipp angesehen.

Schönes Wochenende und auf gut Virtuemart SEO Links ;-)

Beste Grüße,
Yannick
 
 
#6 Chrysovalantis Mochlas 2009-08-20 13:47
Bitteschön!

Das ist gut dass alles funktioniert hat. Für Joomla zur Zeit ist leider der einzige Shop, aber man könnte vielleicht einen anderen externen Shop benutzen wie zB. osCommerce (www.oscommerce.com/) oder ZenCart (www.zen-cart.com/)..gibt's so einigen.
 
 
#5 Holger Weber 2009-08-20 13:01
Vielen Dank für die schnelle Reaktion!

Ich habe mittlerweile ein neues Joomla eingespielt und den Content übernommen, VirtueMart ohne SEO eingespielt und so funktioniert alles wieder.

Natürlich haben Sie recht, dass VirtueMart problematisch ist, aber für Leute, die ihn brauchen ist SEO auch problematisch. Ich habe mich lieber für den Shop und die langen URLs entschieden, vielleicht werden zukünftige Versionen von VirtueMart besser damit zurecht kommen. Ich kenne allerdings für Joomla auch keinen besseren Shop.

Auf jeden Fall noch einmal vielen Dank für Ihre Mühe.
 
 
#4 Chrysovalantis Mochlas 2009-08-20 12:56
Hallo. Haben Sie das mod_rewrite von Apache benutzt? Wenn ja, die Datei .htaccess zurück auf htaccess.txt unbennant? Das könnte die Lösung sein..

VirtueMart ist eine sehr komplizierte Component für Joomla, zur Zeit mit vielen Bugs etc. Vor dem Installation von VirtueMart sollte man sowieso ein Backup von Joomla durchführen, ansonsten kann vieles passieren..und zum Schluss, VirtueMart ist nicht zu empfehlen.

Wenn man SEO nicht braucht muss man von Anfang an wissen..SEO ist für die meisten sehr wichtig -für mich selbst; ohne SEO Webseiten bekommt man keine gute Platzierung in den Suchmaschinen.
 
 
#3 Holger Weber 2009-08-20 11:30
Ich habe in einer Joomla Version die SEO-Einstellungen gesetzt gehabt, soweit funktionierte alles.

Nun benötigte ich VirtueMart und habe die Funktion wieder ausgeschaltet, da man dort sonst auf Unterverzeichnisse nicht zugreifen kann.

Seit dem Ausschalten werden bei mir nun alle Module nur noch angezeigt, wenn sie für alle gelten sollen. Wählt man Module nur für einige Menüpunkte aus, erscheinen sie nun gar nicht mehr ...
 

Unfortunately, you don't have the rights to post any comments.

ValAddThis

On Facebook

Donation

Paypal

Newsletter

Enter your email address:

Delivered by

We have 104 guests online
Copyright © 2019 Val Web Design - Joomla! Development and SEO. All Rights Reserved.